Invalid API 401 responses with valid tokens.
Resolved·Degraded performance

The incident is resolved. API requests will function normally

Tue, May 7, 2024, 10:05 AM
(11 months ago)
·
Affected components
Aiven
Updates

Resolved

The incident is resolved. API requests will function normally

Tue, May 7, 2024, 10:05 AM

Monitoring

Our teams have identified the cause and applied an additional fix. API requests are expected be functioning correctly but our team will continue monitoring issue indicators to make sure this has resolved for all impacted customers.

Mon, May 6, 2024, 06:54 PM(15 hours earlier)

Investigating

While monitoring the issue indicators & doing additional testing we found that the deployed fix did not fully resolve the issue so the team is continuing to investigate the root cause.

Mon, May 6, 2024, 04:29 PM(2 hours earlier)

Monitoring

We have applied a fix to our platform that will resolve this issue. We are continuing to monitor for the issue conditions to confirm that this has been resolved by the aforementioned fix.

Mon, May 6, 2024, 03:23 PM(1 hour earlier)

Identified

We are investigating reports that a small number of API key users are incorrectly receiving 401 response codes ("invalid token") from a subset of API endpoints. Only this set of API endpoints are impacted therefore there is no impact to other platform operations. We have identified the cause and are working on a fix.

Mon, May 6, 2024, 02:53 PM(29 minutes earlier)