Issue affecting disk autoscaler integration for Aiven services
Resolved

Our engineering team has successfully deployed a fix for the issue that was preventing the disk autoscaler from adjusting required disk increases. We have monitored the system and can confirm that automatic disk scaling is now fully operational as expected.

Thu, Aug 21, 2025, 05:10 PM
(1 week ago)
·
Affected components

No components marked as affected

Updates

Resolved

Our engineering team has successfully deployed a fix for the issue that was preventing the disk autoscaler from adjusting required disk increases. We have monitored the system and can confirm that automatic disk scaling is now fully operational as expected.

Thu, Aug 21, 2025, 05:10 PM

Investigating

We have identified an issue with Aiven disk autoscaler, that is currently not scheduling required disk increases to integrated services. All services with integrated disk autoscalers are affected. Our team has started creating a solution for this already. We apologise for any inconvenience. The manual disk increases do still work, so you can still increase the space should you be worried about disk space on your service. We'll update the status as the situation continues.

Thu, Aug 21, 2025, 12:15 PM(4 hours earlier)