Ongoing incident
Resolved
Lasted for 43m

Google services have recovered and we are at the moment not experiencing any more issues.

Mon, Dec 14, 2020, 01:00 PM
3 years ago
Affected components

No components marked as affected

Updates

Resolved

Google services have recovered and we are at the moment not experiencing any more issues.

Mon, Dec 14, 2020, 01:00 PM
43m earlier...

Identified

Some Google services are unavailable. At least support emails are affected. At the moment virtual machines and related resources seem to be working normally but we are monitoring the situation.

Mon, Dec 14, 2020, 12:17 PM