Billing API returns 500 Internal Server Error
Resolved
Degraded performance
Lasted for 3h

A bug in a validation check prevented our API from returning the correct response. Instead, affected customers would get 5xx status code responses. The faulty validation has been removed and our API returns the correct response again.

Fri, Oct 6, 2023, 12:10 PM
7 months ago
Affected components
Aiven
Updates

Resolved

A bug in a validation check prevented our API from returning the correct response. Instead, affected customers would get 5xx status code responses. The faulty validation has been removed and our API returns the correct response again.

Fri, Oct 6, 2023, 12:10 PM
3h earlier...

Identified

We are investigating a problem with our billing API which causes invoices to be returned with a 500 Internal Server Error.

Our engineers have already identified the root cause and are working on a fix.

We apologise for the inconvenience caused by this issue.

Fri, Oct 6, 2023, 08:16 AM