Aiven Console: Kafka Connect: Issue with Available connectors page
Resolved·Partial outage

We have resolved the underlying cause of an issue affecting the "Available connectors" API endpoint and Console page of Kafka Connect.

Should any further issues be encountered, please reach out to support via the Aiven console.

We apologise for the inconvenience caused by this issue, and commit to analysing and improving our platform to avoid future incidents similar to this one.

Thu, May 22, 2025, 05:26 PM
(2 weeks ago)
·
Affected components
Aiven
Updates

Resolved

We have resolved the underlying cause of an issue affecting the "Available connectors" API endpoint and Console page of Kafka Connect.

Should any further issues be encountered, please reach out to support via the Aiven console.

We apologise for the inconvenience caused by this issue, and commit to analysing and improving our platform to avoid future incidents similar to this one.

Thu, May 22, 2025, 05:26 PM

Identified

We have identified the root cause of an issue affecting the "Available connectors" API endpoint and Console page of Kafka Connect. Worker nodes are not affected and creating new connectors should still be possible using the API.

A fix was successfully tested and will be deployed during the next 2 hours.

We apologise for the inconvenience caused by this issue. We will continue to share regular updates.

Thu, May 22, 2025, 01:20 PM(4 hours earlier)

Investigating

We are investigating an issue affecting affecting the "Available connectors" API endpoint and Console page of Kafka Connect. Worker nodes are not affected, only the UI used for creating new connectors.

Our engineers are currently working on a fix.

We apologise for the inconvenience caused by this issue. We will share regular updates.

Thu, May 22, 2025, 12:08 PM(1 hour earlier)