Delayed Node DNS Updates
Resolved·Degraded performance

DNS update functionality has been restored to normal working order.

We apologise for the inconvenience caused by this issue, and commit to analysing and improving our platform to avoid future incidents similar to this one.

Tue, Jul 22, 2025, 04:50 PM
(1 week ago)
·
Affected components
Aiven
Updates

Resolved

DNS update functionality has been restored to normal working order.

We apologise for the inconvenience caused by this issue, and commit to analysing and improving our platform to avoid future incidents similar to this one.

Tue, Jul 22, 2025, 04:50 PM

Monitoring

The DNS update backlog has been processed and DNS updates are occurring normally. We are continuing to monitor this system for anomalies.

Tue, Jul 22, 2025, 04:25 PM(25 minutes earlier)

Monitoring

The DNS issue is resolving, and the platform is working through a backlog of DNS changes.  Node startups may still be delayed for a short period, but we expect things to return to normal timing by 16:00 UTC

Tue, Jul 22, 2025, 03:36 PM(48 minutes earlier)

Investigating

We are investigating reports of delayed DNS updates impacting node startup times in all regions.

We apologise for the inconvenience caused by this issue. We will provide a further update at approximately 16:00 UTC

Tue, Jul 22, 2025, 02:58 PM(38 minutes earlier)