The root cause of this incident has been fixed. All impacted PostgreSQL 18 nodes are operating normally.
We apologize for any inconvenience this may have caused. If you continue to experience any issues with your PostgreSQL services, please contact our support team for assistance.
Resolved
The root cause of this incident has been fixed. All impacted PostgreSQL 18 nodes are operating normally.
We apologize for any inconvenience this may have caused. If you continue to experience any issues with your PostgreSQL services, please contact our support team for assistance.
Monitoring
All impacted nodes in PostgreSQL services have been restored and are now operational. As referenced in the previous update, mitigation measures for new nodes continue to be in effect.
Our engineering team has identified the root cause of this incident and is currently developing a permanent fix. The issue is specific to PostgreSQL 18; other PostgreSQL versions are not impacted.
We will continue to closely monitor system performance to ensure continued platform stability.
Monitoring
We identified an issue when trying to upgrade the version of postgres-anonymizer which was preventing new PostgreSQL nodes from starting up correctly. We have now mitigated this issue so all new PostgreSQL services will not encounter issues when starting up.
We are currently working on recycling the nodes in existing PostgreSQL services to apply this fix. Customers can elect to power cycle the service themselves in order to return back to baseline sooner.
If you continue to experience issues, please reach out to Aiven Support.
Investigating
We are currently aware of an issue that is preventing PostgreSQL nodes from being able to start. We are currently working on a fix for this as a priority. We will continue to provide updates via our status page as they become available.