Issue preventing power on of PostgreSQL services
Resolved·Partial outage

We have identified a mitigation to resolve the issues causing PostgreSQL services not being able to be powered on after being powered off.

We are continuing to monitor closely to ensure no further problems.

We apologise for the inconvenience caused by this issue.

Thu, Nov 20, 2025, 12:07 AM
(1 week ago)
·
Affected components
Aiven
Updates

Resolved

We have identified a mitigation to resolve the issues causing PostgreSQL services not being able to be powered on after being powered off.

We are continuing to monitor closely to ensure no further problems.

We apologise for the inconvenience caused by this issue.

Thu, Nov 20, 2025, 12:07 AM

Investigating

We're currently investigating an issue with PostgreSQL services that have been powered off and then subsequently powered back on. When this happens you will notice in the Aiven console that the nodes stay in starting.

This does not currently affect already powered on services, and those services are able to build new nodes correctly during maintenance updates or in the event of a failover.

We're investigating the cause of the issue for possible mitigations that we can apply. We advise not powering off your services if you plan to power them back on.

We'll continue to update the status of this incident here.

Wed, Nov 19, 2025, 11:49 PM(17 minutes earlier)

Investigating

We're currently experiencing an issue powering on PostgreSQL services. This affects services that have been powered off and then subsequently powered back on. When this happens you will notice in the Aiven console that the nodes stay in starting. This does not currently affect already powered on services, and those services are able to build new nodes correctly during maintenance updates or in the event of a failover. We're investigating the cause of the issue for possible mitigations that we can apply. We'll continue to update the status of this incident here.

Wed, Nov 19, 2025, 10:05 PM(1 hour earlier)