Investigating connectivity issues in Azure Norway West region
Resolved

We have confirmed that all the Aiven services running on the Microsoft Azure region are operational.

If you face any further issues please contact Aiven support.

Sat, Dec 6, 2025, 03:35 AM
(2 days ago)
·
Affected components

No components marked as affected

Updates

Resolved

We have confirmed that all the Aiven services running on the Microsoft Azure region are operational.

If you face any further issues please contact Aiven support.

Sat, Dec 6, 2025, 03:35 AM

Monitoring

We continue monitoring the updates provide by Microsoft Azure, the current status is:

Current Status: We’ve made significant progress in restoring services within the Norway West region. Cooling and power systems are stable, along with the temperatures, and network resources are fully operational. Some of the services are seeing recovery. Event Hubs is fully recovered. Most compute resources are back online; a vast majority of Virtual Machines are also performing well, and Azure Kubernetes Service is also starting to recover. ExpressRoute circuits have seen significant recovery progress. The majority of storage clusters are also powered on and operational. Azure SQL DB is also seeing recovery.

We’re continuing a controlled, staged recovery to ensure safety and reliability. Our teams are actively addressing this and validating dependencies to bring these resources online as quickly as possible. We appreciate your patience as we work towards full resolution.

Sat, Dec 6, 2025, 03:10 AM(24 minutes earlier)

Investigating

We have received official confirmation from Microsoft Azure regarding the connectivity and availability issues we observed earlier. Microsoft had identified a cooling infrastructure failure in the Norway West region. To protect hardware integrity due to elevated temperatures, Azure proactively powered down affected compute and storage clusters. This explains the service unreachability and inability to provision new resources that we reported earlier. Current status: The Azure engineering team reports that cooling and power systems have been restored, and temperatures remain stable. Network and storage systems are fully powered, and compute resources are coming online as they complete their final validations. This process requires deliberate sequencing and validation on Azure's end to ensure safe and reliable service restoration and is time intensive. We appreciate your patience as they continue to work towards full resolution.

Fri, Dec 5, 2025, 08:25 PM(6 hours earlier)

Investigating

We have received official confirmation from Microsoft Azure regarding the connectivity and availability issues we observed earlier. Microsoft has identified a cooling infrastructure failure in the Norway West region. To protect hardware integrity due to elevated temperatures, Azure has proactively powered down affected compute and storage clusters. This explains the service unreachability and inability to provision new resources that we reported earlier. Current status: Cooling and power systems have been restored, and temperatures are now stable, according to the Azure engineering team. They are now proceeding with a controlled, staged power restoration, prioritizing network, storage, and compute resources to ensure a safe and reliable recovery. Azure network and storage resources have been powered on, and their compute power-on operations is progressing. Already 50% have been re-energized. We are awaiting further updates from Microsoft regarding the full restoration of their services.

Fri, Dec 5, 2025, 07:00 PM(1 hour earlier)

Investigating

We have received official confirmation from Microsoft Azure regarding the connectivity and availability issues we observed earlier. Microsoft has identified a cooling infrastructure failure in the Norway West region. To protect hardware integrity due to elevated temperatures, Azure has proactively powered down affected compute and storage clusters. This explains the service unreachability and inability to provision new resources that we reported earlier. Current Status: Cooling restoration efforts are progressing well and Azure engineering teams are currently preparing to execute a carefully phased power-up of core systems once stable conditions are confirmed. We are awaiting further updates from Microsoft regarding the cooling restoration and will notify you when the power-up sequence begins.

Fri, Dec 5, 2025, 04:53 PM(2 hours earlier)

Investigating

We have received official confirmation from Microsoft Azure regarding the connectivity and availability issues we observed earlier. Microsoft has identified a cooling infrastructure failure in the Norway West region. To protect hardware integrity due to elevated temperatures, Azure has proactively powered down affected compute and storage clusters. This explains the service unreachability and inability to provision new resources that we reported earlier. Current Status: Azure engineering teams are working to restore cooling. Once stable, they will begin a safe, phased power-up of the infrastructure. We are awaiting further updates from Microsoft regarding the cooling restoration and will notify you as soon as the power-up sequence begins.

Fri, Dec 5, 2025, 01:58 PM(2 hours earlier)

Investigating

We are currently investigating reports of degraded performance and connectivity errors impacting services hosted in the Azure Norway North region. Some services have become unreachable, creating a new service in the region doesn't work either. Although the official Azure Status page currently reports all systems as operational, our internal monitoring and engineering teams are observing elevated error rates and latency in this region. We apologise for the inconvenience caused by this issue.

Fri, Dec 5, 2025, 07:19 AM(6 hours earlier)