Resolved
We are confirming that the platfom has remained stable following the resolution of the DNS update performance issue, and the system is handling expected load variations well. We are now closing the incident after extended monitoring.
Monitoring
We have resolved the degraded performance issue affecting DNS updates. Customer actions requiring a DNS update (e.g., node replacements) can now be performed without caution.
We are continuing to closely monitor the environment to ensure stability of the platform.
Investigating
We are continuing to investigate degraded performance of our DNS updates. Customers are recommended to avoid any action which will cause a DNS update (IE: a node replacement) out an abundance of caution.
Our engineers have identified the issue and are now working on potential mitigations.
Investigating
We are investigating a delay for new nodes coming online.
Our engineers are actively working on a resolution.
We apologize for any inconvenience this may cause.
We will provide another update as soon as more information is available.