Delays in Service Provisioning on UpCloud
Resolved

The issue affecting node creation on the UpCloud cloud platform has been fully resolved. New services and replacement nodes are now provisioning successfully across all UpCloud regions. Our engineering team has completed all remediation steps and confirmed the stability of the platform.

Wed, Dec 17, 2025, 01:58 PM
(6 days ago)
·
Affected components

No components marked as affected

Updates

Resolved

The issue affecting node creation on the UpCloud cloud platform has been fully resolved. New services and replacement nodes are now provisioning successfully across all UpCloud regions. Our engineering team has completed all remediation steps and confirmed the stability of the platform.

Wed, Dec 17, 2025, 01:58 PM

Identified

Node creation operations are now performing within normal parameters across all UpCloud regions. Our team is currently working through residual issues to ensure full stability. We will continue to monitor the situation closely and provide further updates.

Fri, Dec 12, 2025, 09:20 PM(4 days earlier)

Investigating

We are currently experiencing issues with node creation on the UpCloud cloud platform. This may result in longer than usual start-up times for new services or replacement nodes in all UpCloud regions. Our engineering team is actively investigating the issue with UpCloud to resolve it as quickly as possible.

Fri, Dec 12, 2025, 11:33 AM(9 hours earlier)