We have resolved the underlying cause of this issue.
Should any further issues be encountered, please reach out to support via the Aiven console.
We apologise for the inconvenience caused by this issue, and commit to analysing and improving our platform to avoid future incidents similar to this one.
Resolved
We have resolved the underlying cause of this issue.
Should any further issues be encountered, please reach out to support via the Aiven console.
We apologise for the inconvenience caused by this issue, and commit to analysing and improving our platform to avoid future incidents similar to this one.
Monitoring
We have implemented a mitigation for the infrastructure issue affecting node lifecycle management, and we are now seeing service operations return to normal.
We are closely monitoring the platform to ensure stability. Pending operations such as service creations, deletions, and maintenance updates are beginning to process, though it may take some time to clear the remaining backlog.Investigating
We have identified that the previously reported issue affecting node lifecycle management is not isolated to a single cloud provider, but is currently affecting services across all cloud providers.
As a result, any operations that require creating, or replacing nodes will experience significant delays regardless of the underlying cloud hosting platform. We have stopped all pending maintenance updates to help mitigate the impact.
Impacted operations across all providers include:
- Creating new services
- Powering services up
- Scheduled maintenance updates
- Service scaling and plan upgrades
Note: Aiven for MySQL services are completely unaffected by this issue. For all other service types, existing, running services remain unaffected and continue to operate normally. Our engineering teams are actively working to resolve the root cause across our infrastructure, and we will provide further updates as the situation develops. We apologize for the continued inconvenience.
Investigating
We are currently investigating an issue affecting services running on DigitalOcean that is causing delays in node lifecycle management. As a result, any operations on DigitalOcean-hosted services that require creating, deleting, or replacing nodes will experience delays.
Impacted operations (on DigitalOcean only) include:
Creating new services
Deleting existing services
Powering services up or down
Scheduled maintenance updates
Service scaling and plan upgrades
Note: Existing, running services on DigitalOcean are currently unaffected and operating normally. Services running on other cloud providers (AWS, GCP, Azure, UpCloud) are completely unaffected. Our engineering team is actively working to resolve the issue, and we will provide further updates as soon as more information is available. We apologize for the inconvenience.