MySQL version 8.0.30 will fail to create basebackups
Incident Report for Aiven
Update
Our Engineering team have deployed the permanent fix to the backup failure issue in MySQL 8.0.30. No more services will be affected due to this. Currently, we are working on rolling out a maintenance update to recycle the already-affected services.
Posted Nov 27, 2022 - 06:39 UTC
Update
Our Engineering team have deployed the permanent fix to the backup failure issue in MySQL 8.0.30. No more services will be affected due to this.

Maintenance updates to recycle the already-affected services are ongoing.
Posted Nov 26, 2022 - 21:49 UTC
Update
Our Engineering team have deployed the permanent fix to the backup failure issue in MySQL 8.0.30. No more services will be affected due to this. Currently, we are working on rolling out a maintenance update to recycle the already-affected services.
Posted Nov 26, 2022 - 15:04 UTC
Update
Our Engineering team have deployed the permanent fix to the backup failure issue in MySQL 8.0.30. No more services will be affected due to this. Currently, we are working on rolling out a maintenance update to recycle the already-affected services.
Posted Nov 26, 2022 - 10:38 UTC
Update
Our Engineering team have deployed the permanent fix to the backup failure issue in MySQL 8.0.30. No more services will be affected due to this. Currently, we are working on rolling out a maintenance update to recycle the already-affected services.
Posted Nov 26, 2022 - 06:49 UTC
Update
Our Engineering team have deployed the permanent fix to the backup failure issue in MySQL 8.0.30. No more services will be affected due to this. Currently, we are working on rolling out a maintenance update to recycle the already-affected services.
Posted Nov 26, 2022 - 02:10 UTC
Update
Our Engineering team have deployed the permanent fix to the backup failure issue in MySQL 8.0.30. No more services will be affected due to this. Currently, we are working on rolling out a maintenance update to recycle the already-affected services.
Posted Nov 25, 2022 - 22:32 UTC
Update
We are still working towards deploying the patch, which will mitigate the bug found in MySQL 8.0.30. In the meantime, we have detection tooling in place to detect and fix affected services. Affected services will be mitigated when detected so backups can still be created.
Posted Nov 25, 2022 - 13:51 UTC
Update
We are still working towards deploying the patch, which will mitigate the bug found in MySQL 8.0.30

We now have detection tooling in place to detect services running MySQL 8.0.30, and an ALTER statement has been executed. Affected services will be mitigated when detected so backups can still be created.

We will provide further updates when fixes begin to roll out.
Posted Nov 25, 2022 - 07:12 UTC
Update
We are still working towards deploying the patch, which will mitigate the bug found in MySQL 8.0.30

We now have detection tooling in place to detect services running MySQL 8.0.30, and an ALTER statement has been executed. Affected services will be mitigated when detected so backups can still be created.

We will provide further updates when fixes begin to roll out.
Posted Nov 24, 2022 - 23:13 UTC
Update
Our engineering team have devised the patch to fix the backup issue with MySQL 8.0.30 and we are currently fixing the affected services. We are also working simultaneously for the permanent fix that will be rolled out to all the services.
Posted Nov 24, 2022 - 17:49 UTC
Update
Our engineering team is still working on a patch to fix the backup issue on MySQL 8.0.30 services. We will first fix the affected services, then will later roll out a permanent fix to all MySQL services
Posted Nov 24, 2022 - 13:03 UTC
Update
Our engineering team is currently working on a patch to fix the backup issue on MySQL 8.0.30 services
Posted Nov 24, 2022 - 09:15 UTC
Identified
We are aware of a problem affecting MySQL services running on version 8.0.30, preventing the service from taking base backups. Specifically, the backup procedure will fail whenever an ALTER TABLE statement has been made in 8.0.30.

If you have MySQL services with versions below 8.0.30, we recommend that you do not apply any maintenance updates, change the plan or migrate to a different cloud in order to not be affected by this backup problem.

If your MySQL is running on 8.0.30 and notice any issues, you can contact us via support@aiven.io so that we are able to guide you further.

Our engineers are currently working on mitigating the problem with a patch. We apologise for any inconvenience.
Posted Nov 24, 2022 - 07:02 UTC