Forced restart on PostgreSQL services
Incident Report for Aiven
Resolved
We have now deployed a fix which resolves this issue.

If you are still experiencing issues with your PostgreSQL service, please contact Aiven Support for assistance.
Posted Mar 06, 2023 - 05:55 UTC
Monitoring
We are mitigating impacted service and customers should not experience issues.

If you are experiencing issues with your PostgreSQL service, please reach out to Aiven support for assistance.
Posted Mar 06, 2023 - 00:45 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 14:01 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 13:07 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 11:40 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 08:48 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 05:48 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 04:45 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 03:43 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services while the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 02:34 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services, meanwhile, the emergency procedure in place is being executed on a regular basis to avoid further issues.
Posted Mar 05, 2023 - 01:17 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services, meanwhile, the emergency procedure in place is being executed on a regular basis throughout the day to avoid further issues.
Posted Mar 05, 2023 - 00:18 UTC
Update
Our team continues to work towards a permanent fix for new PostgreSQL services, meanwhile, the emergency procedure in place is being executed on a regular basis throughout the day to avoid further issues.
Posted Mar 04, 2023 - 22:22 UTC
Update
A permanent fix for the new PostgreSQL services is in progress, in the meanwhile an emergency procedure is in place to patch the services that might be affected by this condition, this is done regularly through the day.
Posted Mar 04, 2023 - 14:01 UTC
Update
A permanent fix for the new PostgreSQL services is in progress, in the meanwhile an emergency procedure is in place to patch the services that might be affected by this condition.
Posted Mar 04, 2023 - 13:00 UTC
Update
At this point, the problem for all the existing PostgreSQL services is fixed. We're actively working on resolving the problem that's isolated to new PostgreSQL services only.
Posted Mar 04, 2023 - 09:21 UTC
Update
At this point, the problem for all the existing PostgreSQL services is fixed. We're actively working on resolving the problem on new PostgreSQL services.
Posted Mar 04, 2023 - 07:53 UTC
Update
We have completed patching of existing PostgreSQL services however, new PostgreSQL services are still impacted. Our team is continuing investigations into resolving this issue for new PostgreSQL services.
Posted Mar 04, 2023 - 05:49 UTC
Update
We have completed patching of existing PostgreSQL services however, new PostgreSQL services are still impacted. Our team is continuing investigations into resolving this issue for new PostgreSQL services.
Posted Mar 04, 2023 - 04:33 UTC
Update
We have completed patching of existing PostgreSQL services however, new PostgreSQL services are still impacted. Our team is continuing investigations into resolving this issue for new PostgreSQL services.
Posted Mar 04, 2023 - 03:26 UTC
Update
We have completed patching of existing PostgreSQL services however, new PostgreSQL services are still impacted. Our team is continuing investigations into resolving this issue for new PostgreSQL services.
Posted Mar 04, 2023 - 01:30 UTC
Update
We have completed patching of existing PostgreSQL services however, new PostgreSQL services are still impacted. Our team is continuing investigations into resolving this issue for new PostgreSQL services.
Posted Mar 04, 2023 - 00:16 UTC
Update
We have completed patching of existing PostgreSQL services however, new PostgreSQL services are still impacted. Our team is continuing investigations into resolving this issue for new PostgreSQL services.
Posted Mar 03, 2023 - 22:31 UTC
Update
We have identified the root cause of the problem, and we are working on the fix. PostgreSQL services whose nodes are created at or later than Feb 23 07:10 UTC are impacted.
Posted Mar 03, 2023 - 20:55 UTC
Identified
We have identified a problem that causes PostgreSQL services restart every day. Our engineering team is addressing this problem and working on the fix. We will provide updates on the progress on this page shortly. We've disabled automatic maintenance update for all services temporarily. Before the fix is deployed, please avoid maintenance update and service plan changes that triggers recycle.
Posted Mar 03, 2023 - 19:24 UTC